Back to overview
Downtime
Cloudflare outage
Jun 12 at 09:15am HDT
Affected services
kystdata.io
nordicusv.com
Resolved
Jun 12 at 11:19am HDT
Outage resolved
Affected services
nordicusv.com
kystdata.io
Created
Jun 12 at 09:15am HDT
Kystdata is currently unavailable due to a major cloudflare outage.
Read more: https://www.cloudflarestatus.com/incidents/25r9t0vz99rp
Affected services
nordicusv.com
kystdata.io